VA Chatbot for a localised language is responding in English
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VA Chatbot for a localised language is responding in English

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Article ID: 279027

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

The VA Chatbot was implemented for a language other than English.  But when interacting with the chatbot, it is responding in English

Environment

Release:  17.3 and higher

CA Service Desk Manager/Aria Chatbot

Cause

backend configuration files were not modified correctly

Resolution

The following instructions use the Portuguese implementation of the chatbot as an example:

Go over the following three files:  config.yml, nlu.yml, and domain.yml

config.yml:  Located in the root casm-bot folder, make sure the at the lines for language and model are correctly written.  The first 6 lines of the file should read as this for instance:

recipe: default.v1
language: pt

pipeline:
  - name: "SpacyNLP"
    model: "pt_core_news_sm"

 

nlu.yml:  Replace the nlu.yml file that is placed by default with the localised version.

- Go into the VA directory's casm-bot\data directory. Delete the existing nlu.yml present

- Go into the VA directory's casm-bot\locale\pt\data directory. Copy the existing nlu.yml and paste into the VA directory's casm-bot\data location

 

domain.yml:  Replace the domain.yml file that is placed by default with the localised version.

- Go into the VA directory's casm-bot directory. Delete the existing domain.yml present

- Go into the VA directory's \casm-bot\locale\pt directory. Copy the existing domain.yml and paste into the VA directory's casm-bot location

Additional Information

Make sure to stop RASA before making any changes, then re-train and run RASA afterwards.  Instructions to install and administer RASA are provided in KB Article 272200