User receives a "Whoops" error when opening a Rally User Story page
search cancel

User receives a "Whoops" error when opening a Rally User Story page

book

Article ID: 276702

calendar_today

Updated On:

Products

Rally SaaS

Issue/Introduction

We have a user who is not able to access the User Stories page.  They keep getting the Ooops, We Hit a Snag error message. 

Cause

The issue is caused by a corrupt or invalid saved user preference. 

Resolution

  1. On your dashboard or a custom page, add the "Custom HTML" app from the App Catalog.
  2. Paste the Preference Deleter code from this URL into the HTML section of the Custom HTML app. and select <Save>.
  3. You will be prompted to enter the Preference Name.  Enter:  data-table-default/-200043
  4. Make sure there are no beginning or ending spaces in the entry and click Find Preference.
  5. For each preference that is found, please click the Delete button and confirm Delete Preference Permanently.
  6. Once you have deleted all preferences, click the Find Preference button again and ensure that you see a popup box titled Preference Not Found.
  7. Perform steps 3 - 6 above for the following preference too:  dataTable-user-preferences
  8. Logout immediately (don't navigate to any other page, so as not to save any additional preferences).
  9. Now when you login the User Story page has been reset to its default and will load correctly and allow the user to access the page.

See this video for a walkthrough on adding a custom app