Deployment Solution 8.7.1 Image transfers fail over HTTPs/HTTP when Image name contains a space character
search cancel

Deployment Solution 8.7.1 Image transfers fail over HTTPs/HTTP when Image name contains a space character

book

Article ID: 276166

calendar_today

Updated On:

Products

Deployment Solution

Issue/Introduction

After upgrading to Deployment Solution 8.7.1, capturing/deploying an image containing a space in the name will only transfer over UNC package codebase. If HTTPs/HTTP package codebases are published and configured for Imaging, it may be noticed that Ghost64.exe will open and close 1-3 times before attempting to transfer over UNC (if configured). When Ghost64.exe crashes it will also create a ghosterr.txt log on the client in the following location: X:\Program Files\Symantec\Deployment\Logs (while in automation). ghosterr.txt logs may show the following:

Error Number: 51929
Message: Invalid URL failed to open the image file. 
 HTTP Result: 400, SSL error: 0
Version: 12.0.0.11573

A similar error will also be visible in task/job status in the Symantec Management Console.

If UNC codebase is not published and configured for Imaging and the Image name contains a space, Image transfers will not be possible and result in failed Imaging tasks with similar errors.

If HTTPs/HTTP codebases are normally used for imaging, transfer speeds may slow down causing imaging tasks to run longer with UNC.

Environment

Deployment Solution 8.7.1

Imaging Package codebases configured for HTTPs or HTTP

Image name (Capture or Deploy) contains a space in the name

Cause

There is an issue with URL encoding with Ghost64.exe version 12.0.0.11573 which is included in DS 8.7.1

Resolution

Broadcom developers have released a drop-in fix for this issue.

Instructions for drop-in fix:

  1. Download Ghost_11577.zip attached to this article and extract on the Notification Server/SMP to the desktop or directory separate from ITMS install. The zip file contains a new ghost executable and a related .dll file.
  2. Open Settings > Deployment > Global Settings and verify Image package codebases as well as 'Imaging tools usage by tasks:'



If Imaging tools usage by tasks is set to 'Download from the server':

  • Open File Explorer on the Notification Server/SMP
  • Navigate to '\Program Files\Altiris\Deployment\Imaging\ghost\x64'
  • Back up 2 files. Ghost64.exe AND GhostImageFile64.dll. Copy/save both files in a directory separate from ITMS installation then delete both files from '\Program Files\Altiris\Deployment\Imaging\ghost\x64'
  • Copy Ghost64.exe and GhostImageFile64.dll from the extracted Ghost_11577.zip attached to this case.
  • Place both files in '\Program Files\Altiris\Deployment\Imaging\ghost\x64' (replacing the files that were just removed).
  • Now the updated binaries will be used and 'Downloaded from the server' as specified in Settings > Deployment > Global Settings. No further changes should be needed.

If Imaging tools usage by tasks is set to 'Use from a preboot image':

  • Open File Explorer on the Notification Server/SMP
  • Navigate to '\Program Files\Altiris\Deployment\BDC\bootwiz\oem\DS\winpe\x64\Base\Program Files\Symantec\Deployment\Ghost'
  • Back up 2 files. Ghost64.exe AND GhostImageFile64.dll. Copy/save both files in a directory separate from ITMS installation then delete both files from '\Program Files\Altiris\Deployment\BDC\bootwiz\oem\DS\winpe\x64\Base\Program Files\Symantec\Deployment\Ghost'
  • Copy Ghost64.exe and GhostImageFile64.dll from the extracted Ghost_11577.zip attached to this case.
  • Place both files in '\Program Files\Altiris\Deployment\BDC\bootwiz\oem\DS\winpe\x64\Base\Program Files\Symantec\Deployment\Ghost' (replacing the files that were just removed).
  • Open the Symantec Management Console and navigate to 'Settings' > 'All Settings' > 'Deployment' > 'Packages' > 'BDC' and select 'Update Distribution Points'
  • Rebuild/'Recreate Preboot Environment' for any PXE, iPXE, or Automation Folder configurations you would like to apply the fix to. This can be accomplished in 'Settings' > 'Deployment' > 'Manage Preboot Configurations'
  • Once PXE, iPXE, and AF are rebuilt, Images shouldn't have any problem transferring over HTTPs/HTTP if configured.

 

 

Attachments

Ghost_11577.zip get_app