Can't connect to the database error when installing Service Management
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Can't connect to the database error when installing Service Management

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Article ID: 229068

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

While performing the installation of the Service Management suite in Advanced Availability, database patching fails. 

In the NX_ROOT/log/configure.log we see this message:

INFO  ConfigThread.java      598 Configuration progress : 12 out of 28 tasks completed.
INFO  ConfigThread.java      558 Executing task# 13, task name : Applying patches
INFO  Task.java              214 Running: Applying patches
INFO  PatchDatabaseTask.java   353 Executing altArgs >sql_check_db -c  -s <Server Name>  -o mdbadmin -d mdb -U mdbadmin -p <DB password> -n 
INFO  ?                        ? Process NX_ROOT\bin\sql_check_db.exe completed with exit code 99
ERROR PatchDatabaseTask.java   607 Can't connect to the database.

Environment

Release : 17.x

Database: SQL Server 

Cause

Missing database libraries required to connect to the database server

Resolution

In a SDM Advanced Availability Configuration, the database Client tools for Microsoft SQL Server are required on SDM standby server, background server, and application servers. 

Refer to the following link for the database requirements and links to find the necessary drivers:

SDM SQL Server (2016, 2017, 2019 or 2022) Database Requirements

Once the drivers are installed, retry the installation.

Additional Information

Please review AHD50060:Database check FAILED - sql_check_db -c Exit Code 99: Possible Causes for additional causes.