Error: Failed to create a persistent session in Session Services in PS
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Error: Failed to create a persistent session in Session Services in PS

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Article ID: 145273

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) SITEMINDER

Issue/Introduction

 

The below errors show up in the Policy Server trace whilst trying to connect to the Policy Server from Microsoft Azure using OpenID:

[02/17/2020][15:43:21.431][1044][7436][Sm_Auth_Message.cpp:5338][CSm_Auth_Message::FormatAttribute][Send response attribute 158, data size is 55][][<User ID>][][OpenID Connect][OpenID Connect Realm][][][UserStore][sps_agent][][s269245/r3377][][][][][][][][][][][][Basic][][][][][][][####][][][<Transaction ID>][][][][][][][][][][][Login][Failed to create persistent session in Session Services][...]

[02/17/2020][15:43:21.431][1044][7436][Sm_Auth_Message.cpp:4835][CSm_Auth_Message::SendReply][** Status: Not Authenticated. Failed to create persistent session in Session Services][][<User ID>][][OpenID Connect][OpenID Connect Realm][][][UserStore][sps_agent][][s269245/r3377][][][][][][][][][][Failed to create persistent session in Session Services][][Basic][][][][][][][<User ID>][][][<Transaction ID>]

 

Cause

 

The issue occurred because the Session Store isn't configured when the requested realms are configured as persistent (1).

 

Resolution

 

Configure the Session Store and enable Session Store checkbox on Smconsole (2).

 

Additional Information

 

(1)

    Realm Dialog Reference
    

(2)

    Session Store Configuration