MSP: Task Start/Finish dates are pushed out when resources are allocated at a low amount
search cancel

MSP: Task Start/Finish dates are pushed out when resources are allocated at a low amount

book

Article ID: 98871

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When opening a project from Clarity to Microsoft Project (MSP), some task finish dates move (task duration increases) if the resource is allocated at a low amount to the task. You may see the start date change instead if there is a constraint on the Finish date. 

Steps to Reproduce:

  1. Create a new project in Clarity
  2. Allocate a resource to the project at a low amount (in this example 10%)
  3. Create a new task
    • Task type: Fixed Units (Fixed Duration check box is unchecked)
    • Assign the resource added in step 2 to the task
    • Make the task a one day duration task (In this example, Start/Finish dates are 5/30/2018 for the task)
    • Add 8 hours of ETC for the assignment
  4. Open the project in MSP

Expected Results: Task remains as one day duration with Start/Finish Date of 5/30/2018
Actual Results: Task increases to 10 days, pushing the finish date out to 6/12/2018

Environment

Release: All Supported

Cause

This is due to the resource being allocated at a low amount on the project. MSP is increasing the duration of the task, which pushes out the Finish Date of the task, as it will take more time to complete the tasks based on the ETC on the assignment and the amount of time they are allocated (available) to work on the task. 

Note: When exporting a project from Clarity to MSP, the allocation assigned to the resource in MSP is the allocation assigned to the resource on the project on the day the project is exported to MSP.

Resolution

In order to minimize the risk of dates changing there are a few options:

Increase the resource's allocation on the project

Ensure that the allocation amount covers the date the project is opened in MSP

Map MSP Assignments Units to the PPM Assignment 'Max % Load'

  1. In Administration->Project Management->Settings, check the check box for 'MSP Assignment Units Mapping with PPM Assignment ‘Max % Load'’
  2. Update the Max % Load for the assignment: 
    1. In Clarity go to a task that has the issue
    2. Click Options->Configure in the Assignments section of the task 
    3. Bring ‘Max % Load’ over to 'Selected Columns' and save 
    4. Change the 'Max % Load' value for the assignment to 100 (or the desired allocation)
    5. Click Save 

Notes:

  • When using this setting, it's also important to ensure the assignment's Max % Load is set at the preferred units
  • Test this setting out in non production first as this can impact data based on your configuration

Change the task type to Fixed Duration

This will reduce the risk of the task date being pushed out.

Notes:
  • MSP may still push out Fixed Duration task dates at times but will warn you when you open the project from Clarity first. (One example of when this can occur: When a resource is overallocated on a task)
  • See: MSP: Task Integration with Classic PPM for information on the differences between Fixed Duration and other task types, including information on how information is calculated based on different task types: Work, Units, and Duration (WUD)

Additional Information