search cancel

Custom Jasper report: "Error Details The server has encountered an error"

book

Article ID: 97843

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

A single custom report is not working after upgrading the environment. Other custom reports are running fine. Out of the Box (OOTB) reports are running successfully.

Error Message:

Error Details The server has encountered an error. Please excuse the inconvenience.

Error Message An error has occurred. Please contact your system administrator. (6632)

Checking the Jasperserver.log, an error similar to the below displays:


com.jaspersoft.jasperserver.api.JSSecurityException: An error has occurred. Please contact your system administrator. (6632) at com.jaspersoft.jasperserver.api.security.validators.ValidatorImpl.validateSQL(ValidatorImpl.java:394)

Cause

Based on the 6632 error, this likely indicates invalid underlying SQL queries

Example: the semicolon (;) character is forbidden in queries by an input validation rule on the server with the intent to prevent malicious attacks against the server to filtrate data: Configuring Input Validation

Environment

Release: All Supported Releases
Component: Clarity Jaspersoft

Resolution

Contact your Report Developer to edit the custom report in Studio and fix the SQL validation error by replacing the ';' character with a comma character ','.