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SAML Service Provider objects are not able to be added to workspace in WAMUI

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Article ID: 95745

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

“SAML Service Provider” objects are not able to be added to workspace in WAMUI

Cause

The WAMUI was accidentally added with the listing of objects that are :Child Objects" and are not allowed to be entered direclty into workspaces. Only "Parent Objects" are allowed.

Environment

Release:
Component: SMFSS

Resolution

To resolve the issue of listing Child Objects, we will need to remove them and re-register the AdmiNNUI

1) stop wamui service 
2) edit CA\SiteMinder\adminui\standalone\deployments\iam_siteminder.ear\user_console.war\META-INF\SiteMinderRoleDefinitions.xml, 
remove 3 following 3 lines 
<Property name="ObjectType.32">SMSAMLV1SP</Property> 
<Property name="ObjectType.33">SMSAMLV2SP</Property> 
<Property name="ObjectType.34">SMWSFEDSP</Property> 

3) remove/rename CA\SiteMinder\adminui\standalone\data 
4) run on the Policy Server side: XPSRegClient siteminder:<SU_PWD> -adminui-setup 
5) start wamui service
6) Do the initial login

You will no longer see the SAML Child objects for workspace entries.