U00029003 Cannot open file 'UC4/TMP(OAAFCNKU)', error code '3101'
search cancel

U00029003 Cannot open file 'UC4/TMP(OAAFCNKU)', error code '3101'

book

Article ID: 89088

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Trying to run a AS/400 job the following error appears in the Job Report:

U00029003 Cannot open file 'UC4/TMP(OAAFCNKU)', error code '3101'

Environment

Release: Automic Workload Automation
Component: AS400 / OS400 Agent

Cause

This error is due to the fact the OS400 Agent TMP file has reached the maximum number of members per file. 
 
The file needs to be cleared in order for the process to continue. 

Resolution

Fixed in 12.3.7 HF1 - An issue has been solved in which AS/400 Job aborted because the Library was already in the list. SBMJOB issued without INLLIBL(*JOBD) OUTQ(*JOBD).
 
Solution:
 
Delete the TMP file and recreate it new. 
 
First, stop the agent. Then, delete the TMP File out of the library with the command: "DLTF FILE(UC4/TMP)" and create it new: "CRTPF FILE(UC4/TMP) RCDLEN(256) MAXMBRS(*NOMAX) SIZE(*NOMAX)". Then restart the agent and try it again.