Agent not starting receive U2001017 error
search cancel

Agent not starting receive U2001017 error

book

Article ID: 87931

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
U2001017 It was not possible to create list socket because port number '' is already in use.

Unable to start Agent and receive the above error message is displayed in the log file of the Agent.

This error may be seen when:
  • Not able to start Agent
  • Agent disconnected
  • Jobs are stuck in status waiting for the host
  • Host is not active in the System Overview
  • Agent is not processing Jobs
Investigation

Files needed for analysis:
  • Agent log file from the time the error occurred (Default location: temp folder of the Agent)
  • Agent log file that contains the startup section or ini file of the Agent. (Default location: bin folder of the Agent)
  • Communication Processes (CP) log files from the time the error occurred. (Default location temp folder of the Automation Engine)
     

Environment

OS Version: N/A

Cause

Cause type:
Configuration
Root Cause: The port number defined in the Agent's .ini file is already in use by another program.

Resolution

Automic components need a port assinged to them that is not used by any other program or other Automic component.

  1. Define a port number in the Agents .ini file that is not used by other programs.

The port number is defined in the [TCP/IP]  section of the Agents .ini file:

[TCP/IP]
port = 

  1. Restart the Agent.


Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A