Error 81 during search: Can't contact LDAP server in Policy Server
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Error 81 during search: Can't contact LDAP server in Policy Server

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Article ID: 8010

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On SITEMINDER

Issue/Introduction


When running a Policy Server which connects to backend LDAP User Stores, from time to time, some ldap error 81 in the smps.log is seen.

 [14784/64][Wed Aug 09 2017 22:51:27][SmDsLdapConnMgr.cpp:1190][ERROR][sm-Ldap-02230] Error# '81' during search: 'error: Can't contact LDAP server' Search Query = 'objectclass=*'

 

Environment

 

Policy Server all versions

 

Cause

 
This message might appear if the LDAP Store closes its connection on its side.

As per design, Policy Server needs the LDAP Store's connections to be readily available.

Policy Server won't end any connection that the backend LDAP Store closes.

When the Policy Server then tries to use such a closed connection, the Policy Server will report LDAP error 81.

Straight away, the Policy Server will close this connection and establish a new one with the same backend LDAP store.

As such, the LDAP Store shouldn't close any connection timeout or other reason.

 

Resolution


To avoid this message, configure the LDAP Backend Store to never close its connection with the Policy Server.