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Upgrade of DSM Manager fails with error 1603 - Error Code 1

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Article ID: 76601

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Upgrade of DSM Manager fails with error 1603.

In file %TEMP%\TRC_INST_ITRM_*.log following error appears :
 
start MDB installation on local machine
failed to set current working directory as <C:\Users\test_user\AppData\Local\Temp\2\ITRM\database>
    error code was set to <0>
isFreshInstall assumed <0>
run command: <C:\Program Files (x86)\CA\SC\Mdb\Windows\jre\bin\java.exe  -Djava.library.path=".\lib"   -classpath .\lib\log4j-1.2.8.jar;.\lib\ojdbc14.jar;.\lib\sqljdbc.jar;.\setup.jar;.\;.\msql\post_install.sql  ca.cms.mdb.setup.Setup  -cfg setup.properties -a  checkprereq_install/install/verifyschema/addusers/postinstall>
LaunchCmd start
LaunchCmd: Process creation succeeded
LaunchCmd: process terminated with exit code  <1>
LaunchCmd end return <TRUE>
MDB setup command error: <1>
Init: end
Schema installation failed [7]

Cause

error code 1 indicates a problem during execution of java.exe process

There are 3 possible causes :

Cause 1 :

The cause of problem is indicated by this line in %TEMP%\TRC_INST_ITRM_*.log :
 
failed to set current working directory as <C:\Users\test_user\AppData\Local\Temp\2\ITRM\database>

 
Cause 2 :
If error described in cause 1 does not appear in the log, check in file C:\Program Files (x86)\CA\DSM\database\setup.log if the log terminates with this line :
 
2018-08-22 14:26:28,861 check pre-requisites started
2018-08-22 14:26:28,861 checkPreReqInstall() in progress ...
2018-08-22 14:26:28,861 testing connection for user  []
 
 
Cause 3 :
If error described in cause 1 and 2 do not appear in the logs, execute following commands
 
cd /D C:\Program Files (x86)\CA\SC\Mdb\Windows\jre\bin
java.exe
 
and check if following error appears :
 
Error occurred during initialization of VM
Could not reserve enough space for 716800KB object heap

Environment

Client Automation - All versions

Resolution

In order to solve this problem do this on Domain ITCM :

For Cause 1 :
 

Open regedit and delete the registry key value TempManagerDir under

HKEY_LOCAL_MACHINE\Software\Wow6432Node\ComputerAssociates\Unicenter ITRM\Installer


For Cause 2 :
 

- Rename the directories :
 
C:\Program Files (x86)\CA\DSM\database as C:\Program Files (x86)\CA\DSM\database.old
C:\Program Files (x86)\CA\SC\Mdb as C:\Program Files (x86)\CA\SC\Mdb.old

 

- Restore these directories from another DOMAIN in same version.
 
For example if problem occurs during upgrade of DOMAIN from 14.0 SP1 to 14.0 SP2, restore these directories from DOMAIN 14.0 SP1
If there is no DOMAIN with same version available, a new DOMAIN machine could be installed on a test machine in order to get the directories.
 
 
For Cause 3 :
 
Set this System environment variable
_JAVA_OPTIONS=-Xmx512M
 
and try again the upgrade

Additional Information

See following document if error is similar but with error code 193 :

During the update of a Domain Manager to r14.*, the upgrade of the MDB fails with error 1603. What can be the reason? - Article ID: 8689

And for error code 2 :

Upgrade of DSM Manager fails with error 1603 - Article ID: 76516