UIM - SDM Validation failed error

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Article ID: 73055

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Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

When integrating CA UIM and CA ServiceDesk Manager, the Validation fails from the sdgtw probe Connection Details Page. We shall be discussing the usual causes of the issue. 

 

 

Cause

The probable causes would normally be:

  1. Incorrect information provided in the Connection Details Page
  2. Issues in Communication between CA UIM hub and the CA ServiceDesk Manager Server

Described in more detail below

Environment

  1. CA UIM (DXIM) - 8.51, 9.x, 20.x
  2. CA ServiceDesk Manager - 14.x, 17.x
  3. sdgtw probe - 1.40 and above
  4. SOAP Protocol - http
  5. REST Protocol - http
  6. SOAP Port - 8080
  7. REST Port - 8050

Resolution

Step 1:
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Ensure the CA Service Desk Manager administrator user is able to successfully login on to the Service Desk Portal from below Web Address (use http or https in accordance with how this has been implemented in your environment):

http://<IP-Address(or)Hostname-of-ServiceDeskManager>:<SOAP_PORT_Number>/CAisd/pdmweb.exe

CA ServiceDesk Manager Login Page from the web browser:


CA ServiceDesk Manager Successful login:





Step 2:
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In the CA Service Desk Manager Connection Details page, verify the details provided

Path:

From Admin Console -> Select the end Hub -> Robots -> select the end Robot -> select Probes -> click on the three vertical dots ... beside sdgtw like below:

-> Now, click on the configure option:


-> In the Probe Configuration Window -> under sdgtw ->  Available Service Desks -> CA Service Desk Manager -> CA Service Desk Manager Connection Details page


-> Verify the information provided is correct, you may want to special attention to the SOAP and REST Protocol and Port numbers



 

Step 3:
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In the sdgtw probe information page, provide the complete path for the nas and the hub probes if remotely installed

Path: Admin Console -> Select the end Hub -> Robots -> select the end Robot -> select Probes -> click on the three vertical dots ... beside sdgtw like below:

-> Now, click on the configure option:


-> In the Probe Configuration Window -> sdgtw

-> Provide the complete path for:

(a) nas probe - format for nas probe:    /<Domain-Name>/<Hub-Name>/<Robot-Name>/nas

(b) hub probe - format for hub probe:   /<Domain-Name>/<Hub-Name>/<Robot-Name>/hub



 

Step 4:
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Verify ports are not blocked

From the UIM Robot where the probe sdgtw is deployed, do a "telnet" to the Service Desk Manager Server through the “SOAP” and “REST” ports as below:


(a) To telnet to the SOAP Port:
===========================

To telnet to the SOAP Port, run the below command:


telnet <IP-Address(or)Hostname-of-ServiceDeskManager> <SOAP Port Number>

If the port is open, then upon running the above command, you would see a new blank screen similar to below which would mean the connection to the SOAP Port is fine:


If the port is blocked, then upon running the above command, you would see "Connect failed message"  similar to below which would mean there are communication issues, probably, the SOAP Port is blocked and you may need to involve the Systems Admin to get the Port Opened:


  

(b) To telnet to the REST Port:
===========================

To telnet to the REST Port, run the below command:

 

telnet <IP-Address(or)Hostname-of-ServiceDeskManager> <REST Port Number>


If the port is open, then upon running the above command, you would see a new blank screen similar to below which would mean the connection to the REST Port is fine:


         

If the port is blocked, then upon running the above command, you would see "Connect failed message"  similar to below which would mean there are communication issues, probably, the REST Port is blocked and you may need to involve the Systems Admin to get the Port Opened:


 

 

Step 5:
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The SOAP Connectivity does not happen

To test SOAP Connectivity, from the web browser, type the following (use http or https in accordance with how this has been implemented in your environment) from the UIM Robot where the probe sdgtw is deployed and ServiceDesk Manager Servers:

http://<IP-Address(or)Hostname-of-ServiceDeskManager>:<SOAP_PORT_Number>/axis/services/USD_R11_WebService?wsdl

If you see the output similar to below, the SOAP communication is fine:

 

If you see the output similar to below, the SOAP communication is not fine and you would need to involve your CA ServiceDesk Administrator:



Step 6:
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The REST Connectivity does not happen

To test REST Connectivity, from the web browser, type the following (use http or https in accordance with how this has been implemented in your environment) from the UIM Robot where the probe sdgtw is deployed and ServiceDesk Manager Servers:

http://<IP-Address(or)Hostname-of-ServiceDeskManager>:8050/caisd-rest/rest_access


If you see the output similar to below, the REST communication is fine:



If you see the output similar to below, the REST communication is not fine and you would need to involve your CA ServiceDesk Administrator:


 

Step 7:
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There could be other reasons as well as explained in other technical documents:

a) Technical Document on "UIM SDM integration - validation failed", to view please click here

b) Technical Document on "Unable to validate cloned Service Desk Manager (SDM) connection (sdgtw probe)", to view please click here

 

 

Additional Information

It would be worth rechecking you are on supported platform and all the pre-requisites have been met, for further information please click here

 
If the issue still exists following all the above steps, please set sdgtw probe to loglevel 5, logsize 20000, recreate the issue. Open a ticket with Broadcom support and upload the following the details to the ticket from the robot where sdgtw probe has been deployed:
 
(a) UIM (DXIM) release
(b) sdgtw release (along with Operating System release)
(c) ServiceDesk Manager release
(d) sdgtw.cfg file
(e) sdgtw log file
(f) _sdgtw log file (if exists) 


 

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