Spectrum Report Manager failing to update events with error "Table 'reporting.event' doesn't exist"
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Spectrum Report Manager failing to update events with error "Table 'reporting.event' doesn't exist"

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Article ID: 5700

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The Spectrum Report Manager (SRM) is failing to update the events for the landscapes being monitored. The Last Event Time is not updating in the OneClick Administration -> Report Manager -> SPECTRUM status page for the landscapes being monitored.

Environment

Release: a7n0c000000PBNr
Component:

Cause

Check the $SPECROOT/tomcat/logs/stdout.log (Windows) catalina.out (Linux) file for the following error message:

 

ERROR 1146 (42S02) at line 21 in file: '/app/spectrum/Install-Tools/rpmgr/sql/srmdbapi/ddl/create_v_fact_event.sql': Table 'reporting.event' doesn't exist

 

Resolution

If the above error is seen, the reporting database will have to be rebuilt from scratch.



  1. Log into the system as the user that owns the Spectrum installation
  2. Shutdown all the Spectrum processes that are running; SpectroSERVER, tomcat, mysql, processd
  3. Remove the ib_logfile* and ibdata files from the $SPECROOT/mysql/data directory
  4. Remove all of the files from the $SPECROOT/mysql/data/reporting directory
  5. Restart the Spectrum processes
  6. Log into the OneClick web pages as an ADMIN user
  7. Go to the Administration -> Report Manager -> SPECTRUM status page
  8. Ensure the landscapes needed are configured for monitoring. If not, configure them for monitoring and verify the Last Event Time is updating.



If the following error is seen when trying to configure landscapes to be monitored, see knowledge document KB000029380 " Getting Error "Unable to access the SRM preferences" when trying to enable monitor option" located at https://knowledge.broadcom.com/external/article?articleId=000029380



 

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