How to configure the integration between Service Catalog and CA SDM
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How to configure the integration between Service Catalog and CA SDM

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Article ID: 5697

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Updated On:

Products

CA Service Catalog CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Integration between Service Catalog and CA SDM fails with below error message

"ERROR [http-bio-80-exec-11] [CConfiguration] CCONF.TESTCONF.EXCPT
com.ca.usm.webservices.WebserviceException: E:\Program Files\CA\Service Catalog\CASM_POLICY (The system cannot find the file specified)"

Or

"Invalid login policy encryption"

Environment

CA Service Management 17.1 and higher.

Cause

Keystore Name is missing the extension of the key file within the Catalog - Service Desk Manager Configuration page.

Resolution

1) Login to Service Desk Manager UI as an Administrator

2) Go to Administration --> Soap Web Services Policy -->Policies

3) Verify that the CASM_POLICY webservices policy exists

4) If it exists then confirm that the "Allow Impersonate" is checked

5) Open a command prompt on the CA SDM Server

and run the following command

        pdm_pki -p CASM_POLICY -f

to create the CASM_POLICY.p12 file

6) Copy the created CASM_POLICY.p12 from CA SDM Server to %USM_HOME on the catalog server

7) Login to Catalog UI as a Service Delivery Administrator go to Administration --> Configuration--> CA ServiceDesk

Set Enable PKI to 'Yes'

Ensure that the Keystore Name is set to CASM_POLICY.p12 (case sensitive)

Ensure that the Policy Code is set to CASM_POLICY (case sensitive)

Additional Information

Note: The original issue occurred because the Keystore name was provided without the extension i.e.  given as "CASM_POLICY" instead of "CASM_POLICY.p12". Once corrected the Test button launch was successful and the functionality worked as per the design.