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ERROR :: SponsorManager::submit :sponsor[ iRegistry] not found and invocation returned 404 error

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Article ID: 49209

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Updated On:

Products

CA Security Command Center CA Data Protection (DataMinder) CA User Activity Reporting

Issue/Introduction

This document explains how to prevent these errors from appearing in the igateway.log:

ERROR :: SponsorManager::submit :sponsor[ iRegistry] not found and invocation returned 404 error

Cause

iRegistry is an optional iSponsor that is part of the iGateway install package.

iRegistry provides iSponsor discovery and enumeration services.
 

This iSponsor is not used with UARM.

 

Environment

Release:
Component: CAELM

Resolution

Even if these errors can be ignored, you can prevent them from appearing in the igateway.log with the following steps:

  1. Stop igateway ( S99igateway stop )
  2. Edit the igateway.conf located in the folder /opt/CA/SharedComponents/iTechnology
  3. Comment the <RegistryHostList> tag completely in igateway.conf as shown below
    ( add <!--  in front of these lines  and add --> after these lines )

    <!--                 <RegistryHostList name="RegistryHost-1">                             <host>localhost</host>                   </RegistryHostList>  -->
  4. Start igateway ( S99igateway start ).
    After this the iRegistry error will not be logged in igateway.log.
     

 

Additional Information

CAELM

https://ftpdocs.broadcom.com/cadocs/0/CA%20User%20Activity%20Reporting%20Module%2012%205%2004-ENU/Bookshelf_Files/PDF/CAELM_Overview_ENU.pdf

UARM

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-identity-manager/14-0/integrating/ca-user-activity-reporting-module-integration/setup-ca-user-activity-reporting-module-environment/configure-a-connection-to-ca-user-activity-reporting-server.html