Error "hs is missing" when trying to start the CA Spectrum SpectroSERVER on Windows
search cancel

Error "hs is missing" when trying to start the CA Spectrum SpectroSERVER on Windows

book

Article ID: 48641

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

The following error is seen when try to start the SpectroSERVER from the Spectrum Control Panel on Windows:

The SpectroSERVER process exited with error: The program can't start because hs is missing from your computer.
Try reinstalling the program to fix this problem.

Environment

Release: Any version of Spectrum installed on Windows
Component:

Cause

However, the missing file is not specified. The reason the missing file is not specified is because the APIs that are used do not allow access to the missing file name.

To find the missing file name, do the following:

  1. Open a Windows cmd
  2. cd to the $SPECROOT/SS directory
  3. Enter the following command to start the SpectroSERVER from the command line:

    SpectroSERVER.exe
  4. You should see an error box with an error similar to the following specifying the missing file. In the example below, the missing file is mtsfm32.dll:

    The program can't start because mtsfm32.dll is missing from your computer.
    Try reinstalling the program to fix this problem.

Resolution

To resolve the issue:

  1. Review the install logs to ensure there were no issues with the installation
  2. Copy the missing file from another Windows system with the same Spectrum version and patches installed

Contact CA Spectrum support for further assistance.