NFA 9.1.2 Polling Issues

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Article ID: 48579

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Updated On:

Products

APPLICATION DELIVERY ANALYSIS SUPERAGENT CA Infrastructure Performance

Issue/Introduction

Description:

There is a NFA 9.1.2 bug that was recently found. The issue revolves around NFA Device and Interface SNMP Polling.

Symptoms:

If you try to run a Test/Discovery/Refresh on a device or interface from Enable Interfaces the NFA poller may become unresponsive and not come back with a (Profile Found/Not Found, Refresh Successful/Failed)

Instead the loading cursor will go around and around until it times out after ten minutes. Devices may turn to yellow or red in the last polled column.

Cause:

There is a bug in the SNMP Profile polling procedure. When there is a disabled Profile in CAPC SNMP Profiles and it syncs down to NFA it causes the time out symptoms.

Solution:

The bug is being tracked in Defect 138121. This problem will be resolved in NFA 9.1.3.

If you are on NFA 9.1.2 you can resolve this issue now with the attached patch.

To apply the patch follow the steps below:

  1. Copy and unzip attached files to the NFA Console (make sure all files are extracted to the same directory)

  2. Run "pollerPatch.bat" to apply all changes to each remote harvester.

    If any errors occur running the pollerPatch.bat script from the NFA console, then login to each harvester and load the sql script from command line as shown below:

    mysql poller < poller_patch.sql

  3. Login to each harvester and restart the CA NFA Poller service.

Environment

Release: RAIB1H99000-9.1-Network Flow Analysis-Interface Bundle-Hardware
Component:

Attachments

1558534933781TEC597527.zip get_app