Spectrum is unable to generate service desk tickets with the error as "Configuration file is missing. Unable to create Service Desk ticket"
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Spectrum is unable to generate service desk tickets with the error as "Configuration file is missing. Unable to create Service Desk ticket"

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Article ID: 48445

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Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum is unable to create service desk tickets automatically using SDNotifer and getting the error as below
Creating Service Desk ticket for alarm: xxxxxxxx-xxxx-xxxx-xxxx-00155d048d01
Missing configuration information. Please check your configuration file.
(Tue Dec 10, 2013, 15:30:49) - Configuration file is missing. Unable to create Service Desk ticket.

 

Environment

Release: Any
Component:

Cause

The $SPECROOT/Notifier/sd_notifier/ServiceDeskIntegrationSetup process not run or the sd-integration.cfg file contains invalid configuration information.

Resolution

Run the $SPECROOT/Notifier/sd_notifier/ServiceDeskIntegrationSetup process:

1. Log into the system as the user that owns the Spectrum installation

2. On Windows, start a bash shell by running "bash -login"

3. cd to the $SPECROOT/Notifier/sd_notifier and enter the following command:

./ServiceDeskIntegrationSetup

4. You will be prompted for the following information:

server -> OneClick server name
port -> OneClick Port
path -> Spectrum installed location default is spectrum press ENTER
user -> OneClick Username
password -> OneClick password

5. When complete, there will be a $SPECROOT/Notifier/sd_notifier/sd-integration.cfg file that contains the configuration information.

Additional Information

Please reference the "Configuring the AlarmNotifier Integration Component for CA Service Desk Manager" section of the documentation for more information.