Missing variables in NX.env after running pdm_configure
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Missing variables in NX.env after running pdm_configure

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Article ID: 45297

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After running pdm_configure, most NX variables are missing from the end of the NX.env file that were there prior to running pdm_configure and The NX.env template file was unchanged and looks correct. At the end of the NX.env file it ends with something like the following or maybe a few lines more:
 
@NX_CMDB=NOTSTANDALONE
@NX_SA_SERVER_ON_PRIMARY=YES
@NX_SERVER_TYPE=1
@NX_BACKGROUND_SERVERS=BACKGROUND1,BACKGROUND2
@NX_RF=1
! @NX_RF_OVERRIDE_LINKED= Deinstalled

Environment

Service Desk Manager 17.X

Cause

pdm_configure uses version control to help create the NX.env. One of the files that is important for this to work correctly is the client_nx.env file located in the site folder of the Service Desk install directory. pdm_configure will pull from the client_nx.env of the active background server and because of this, if the client_nx.env file is incorrect on the active background server, the NX.env file is not created correctly.

Resolution

1.) Navigate to the NX_ROOT\site folder on each Background and Standby server.
2.) Backup each client_nx.env file and open them to compare them.
3.) Take the largest client_nx.env file and copy it and overwrite the other client_nx.env files.
4.) Run pdm_configure on all affected servers and verify the NX.env is now complete.