API-1019 Error Occurs in the 15.1 New UI when Attempting to Open a Project
search cancel

API-1019 Error Occurs in the 15.1 New UI when Attempting to Open a Project

book

Article ID: 4446

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When attempting to open a project using the New UI in PPM 15.1, the project cannot be opened and the following error is thrown:

API-1019: Could not process the request due to internal error 

This occurs only for projects that have a project template selected for the 'Project Template' field that either no longer exists or is marked for deletion. 

 

Steps to Reproduce: 

1. In the Classic UI, go to the Project List and click on 'New from Template' 

2. Select the 'Major Project Template'

3. Enter a project name (Project A) and a value for all other required fields on the new project create page, Save and Return 

4. Configure the 'Project Template' column on the Project List and verify that the 'Major Project Template' value shows on this column for the 'Project A' created on Step 3 

5. Open the 'Major Project Template' project properties and uncheck the 'Active' checkbox 

6. Return to the Project List, and Mark the 'Major Project Template' for deletion 

7. Go to Home > Jobs 

8. Run the Delete Investments job

9. Go to the Project List in the Classic UI, open 'Project A'

10. Notice how 'Project A' opens without an issue in the Classic UI

11. Now go to the New UI

 

12. Click on 'Project A' to open the project

Expected Result: 'Project A' opens in the New UI

Actual Result: The project does not open in the New UI, instead the following error is thrown: 'API-1019- Could not process the request due to internal error.'

Environment

Applies to the New UI in PPM 15.1

Cause

Caused by CLRT-81516

Resolution

This issue no longer occurs in the upcoming PPM 15.2 release. 

Workaround:

Go to the Project list in the Classic UI, the value for the 'Project Template' field for 'Project A' will appear blank. However, in the database this field still shows the internal ID of the Project Template that was deleted. On the Project list, click on the 'Project Template' field, and re-select [--Select--] and click Save in order to clear out the previous value.

To find all projects that have the deleted template previously selected the Project Template field, run the following query: 

 

select code,name from inv_investments 

where id in (select id from odf_ca_project 

where obj_methodology = #######) 

 

The ####### in the above query should be replaced with the internal template ID referenced in the error message corresponding to the API-1019 error in the app-ca logs: 

ERROR 2016-11-08 11:53:42,175 [http-nio-80-exec-88] ppm.rest (clarity:admin:5307019__9ABB3D6A-A7A2-4BC3-A354-60E722B40346:PPM_REST_API) ODFObjectMarshaller :: attribute: obj_methodology has an invalid lookup value: #######