API Gateway version information still shows the previous version after successful upgrade
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API Gateway version information still shows the previous version after successful upgrade

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Article ID: 44315

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Updated On:

Products

STARTER PACK-7 CA Rapid App Security CA API Gateway

Issue/Introduction

The API Gateway server patch management process uses a standard install process for Linux systems involving unpacking RPM's (untar) and running them concurrently. After the Platform update is applied, an Application update is uploaded and then installed. After this is complete, a MySQL DB upgrade is run, which will update the version information for all the patches applied.

Environment

Release:  9.X
Component: APIGTW

Cause

There are two symptoms:

1. Upon completion of the Application update, the System Administrator will attempt to upgrade the mysql db and will receive the message "no database upgrade required". The version of the API Gateway will still show the previous version; even after a reboot. 

2. The upgrade logs will show a successfully installed status;

The patches.log does not state anything other than a UPLOAD and then a INSTALL action was performed

The patch_cli_0_0.log also show a similar message: Running patch action: INSTALL

The sspc_0_0.log will also show a success state:

com.l7tech.server.processcontroller.patching.PatchServiceApiImpl: Patch exit code: 0

com.l7tech.server.processcontroller.patching.PatchServiceApiImpl: Patch Layer7_v9.1.00 is installed.

 This is incorrect. It is indicating merely that the shell script patch task was completed without error. 

In the previous lines of the sspc_0_0.log there is a warning 

WARNING: /tmp does not have enough disk space!

Resolution

Support recommends to keep a minimum of 2 GB system disk space available in /tmp, /home/ssgconfig, and /opt/SecureSpan/Controller/var/patches 

1. Remove all upgrade files that may have been previously installed. (All files with the .L7P extension).

2. The upload will need to be performed again. If the upload fails, remove the .status file in "/opt/SecureSpan/Controller/var/patches"  that represented the previous attempt at installing the same patch.

Logs reviewed:

opt/SecureSpan/Controller/var/logs/sspc_0_0.log

opt/SecureSpan/Controller/var/logs/patch_cli_0_0.log

opt/SecureSpan/Controller/var/logs/patches.log

Additional Information

You may wish to expand the logical volume to support more storage capacity of the Gateway Appliance. Please review Article Id: 42624 for this instruction.