nas probe fails to start with device_limit log message
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nas probe fails to start with device_limit log message

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Article ID: 4427

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After a primary hub restart, it is possible that the nas probe will not start and to see messages like the following in the nas probe log:

Oct 29 14:21:11:235 [139916704651008] nas: device_limit: attempting to 'register_probe' probe_name: 'nas'   probe_address: '/HUB-CLOUD/HUB-PRI/Hub-1/nas'
Oct 29 14:21:11:235 [139915864041216] nas: device_limit:  failed (rc=11) to 'register_probe' probe_name: 'nas'   probe_address: '/HUB-CLOUD/HUB-PRI/Hub-1/nas'
Oct 29 14:21:11:235 [139915864041216] nas: device_limit:  waiting '1' seconds for MPSE to startup.  total: '850372'
Oct 29 14:21:12:228 [139916157626112] nas: replExporter: POST_FAILED_TO_RESOLVE_HUB_TO_NIM_ADDRESS hub_name:'<some hub>'   failures:12085

Environment

Release:
Component: UIMNAS

Cause

This can be caused by having two nas probe processes enabled at the same time.  It is likely that at some point prior to the primary hub reboot, the nas probe had been started from command line.  Before hub restart this extra process did not affect anything.  However, on hub restart this "rogue" nas probe caused a problem for licensing.
This has been reproduced on both Windows and Linux systems with UIM 8.4 and 8.47.

Resolution

To eliminate this error, either:
- "End Task" or pkill the extra nas process and restart nas.
- Or reboot the primary hub server.

Either of these steps will stop the "rogue" nas process and allow the appropriate nas process to function normally.