CA Workload Automation Agent does not start. Exception logged is "Address already in use".
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CA Workload Automation Agent does not start. Exception logged is "Address already in use".

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Article ID: 4411

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Updated On:

Products

Workload Automation Agent

Issue/Introduction

CA Workload Automation Agent does not start. The following error message has been captured in the file 'nohup.stderr' located under the Agent install directory:

Exception in thread "MainThread" cybermation.agent.CybAgentDriver$CybAgentInstantiationError: java.lang.IllegalStateException: cybermation.library.communications.CybConversationException: Address already in use

at cybermation.agent.CybAgentDriver.runApplication(Unknown Source)

at cybermation.agent.CybAgentDriver.main(Unknown Source)

Caused by: cybermation.library.plugins.CybPluginException: java.lang.IllegalStateException: cybermation.library.communications.CybConversationException: Address already in use

at cybermation.agent.controller.CybControllerPluginManager.loadAPlugin(Unknown Source)

at cybermation.agent.controller.CybControllerPluginManager.loadPlugins(Unknown Source)

at cybermation.agent.controller.CybControllerPluginManager.initialize(Unknown Source)

at cybermation.agent.CybAgentDriver.runApplication(Unknown Source)

... 1 more

Caused by: java.lang.IllegalStateException: cybermation.library.communications.CybConversationException: Address already in use

at cybermation.commplugins.tcpip.CybTcpipControllerPlugin.initialize(Unknown Source)

at cybermation.agent.controller.CybControllerPluginManager.loadAPlugin(Unknown Source)

... 4 more

Environment

All the CA Workload Automation Agent version supported platforms

Cause

The communication port number for the CA Workload Automation Agent is defined by the property (communication.inputport=7520) in the agentparm.txt file, which is located under the agent install directory.

This error occurs if the port number defined is already being used by another application or process on the system.

Resolution

Use a different port number If the agent port number is found to be in use by another application or process. The Operating System native commands can be used to determine the status of the port. Examples are provided below:

Linux: 

# lsof -i :7520

COMMAND     PID USER   FD   TYPE   DEVICE SIZE/OFF NODE NAME

myApp.b. 59306 root   54u  IPv6 63729986      0t0  TCP *:7520 (LISTEN)

or

# netstat -nap |grep 7520

tcp6       0      0 :::7520                 :::*                    LISTEN      59306/./myApp.bin

Windows: 

C:\Users\Administrator>netstat -nao |findstr 7520

  TCP    10.##.##.##:7520    10.##.##.##:3389      ESTABLISHED     13768

Ensure the defined port is available before starting the Agent. 

Additional Information

CA Workload Automation Agent supported platforms: Agent Platform Support Matrix