After upgrading from Service Desk 12.1 to 14.1, when searching for incidents by various attributes, status for example, when clicking on the status lookup, I'm taken to the Status Search page rather than to the list of available statuses
search cancel

After upgrading from Service Desk 12.1 to 14.1, when searching for incidents by various attributes, status for example, when clicking on the status lookup, I'm taken to the Status Search page rather than to the list of available statuses

book

Article ID: 4378

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

After upgrading from Service Desk 12.1 to 14.1, when searching for incidents by various attributes, status for example, when clicking on the status lookup, I'm taken to the Status Search page rather than directly to the list of available statuses as in the screenshots below:

<Please see attached file for image>

Search_Incident_1.jpg

<Please see attached file for image>

Search_Incident_2.jpg

<Please see attached file for image>

Search_Incident_3.jpg

In previous releases when clicking on the lookup link for the attribute we were taken straight to the list of available values. In this case, how do we avoid the Incident Status Search page being displayed and go straight to the list of available statuses?

Environment

CA Service Desk Manager r14.x installation upgraded from version 12.1.The problem does not occur on a newly installed Service Desk 14.1 installation

Cause

The problem is caused by the lack of a default_value for the Extra URL parameter on the sflookup macro in the usp_pdmMacroParam table. If you run the following command on the SDM server: 

C:\PROGRA~2\CA\SERVIC~1\>pdm_extract -f "select default_value from usp_pdmMacroParam where macro=1150 and name='extraURL'"

TABLE usp_pdmMacroParam

       default_value

        { "" }

usp_pdmMacroParam

        rows:1

You will probably see that the default_value is empty, "". It should have a value of "QBE.EQ.delete_flag=0". The following steps will add this default value to the Extra URL parameter on the sflookup macro parameter. I suggest run the steps in your test environment prior to running them in production. 

Resolution

Use the following steps on the Service Desk server to resolve the problem:

 

1. Copy the following into a text file called upd_macro_param.dat 

TABLE usp_pdmMacroParam

caption default_value del description help_form id is_advanced is_required

last_mod_by last_mod_dt macro name name_val_localized size_textbox tooltip

type value_list 

{ "Extra URL" ,"QBE.EQ.delete_flag=0" ,"0",

"For passing extra URL information.  Not for general use.",

"-properties_extraURL_index.html" ,"1487" ,"1" ,"0" ,"" ,"" ,"1150",

"extraURL" ,"0" ,"" ,"For passing extra URL information" ,"1" ,"" }

 

2. Now take a backup of the usp_pdmMacroParam table:

- pdm_extract usp_pdmMacroParam > usp_pdmmacroParam_bkp.dat 

 

3. Now update the table using the file created in step 1:

- pdm_load -f upd_macro_param.dat 

 

4. Clear the table and webcache.

- pdm_cache_refresh -t usp_pdmMacroParam 

- pdm_webcache 

 

5. Clear your browser cache.

 

Now login to Service Desk and test the Incident Search page and verify that that the list of values is displayed immediately after clicking on the lookup link for the desired attribute. 

Attachments

1558699931064000004378_sktwi1f5rjvs16out.jpeg get_app
1558699929297000004378_sktwi1f5rjvs16ous.jpeg get_app
1558699927548000004378_sktwi1f5rjvs16our.jpeg get_app