Reinstall Process Automation
search cancel

Reinstall Process Automation

book

Article ID: 437734

calendar_today

Updated On:

Products

CA Process Automation Base Process Automation Manager

Issue/Introduction

The following article discusses how to perform a reinstall of Process Automation.  You may be asked to perform this task by Support or to update any PAM related components

Environment

Release:  4.4 and higher

Cause

A common misconception when being told to "reinstall" is that the existing product install must be uninstalled first.  This is NOT the case with Process Automation.  A "reinstall" activity for PAM is more akin to running a "repair" or "modify" of the existing PAM instance, that is, the original PAM install does not need to be uninstalled first.

Resolution

To reinstall the PAM product:

  1. Download the two ISO deliverables, one containing the Third Party Components, the other containing the CA Process Automation installer.
  2. Extract the ISO contents into separate folders, one for the Third Party Components, the other containing the CA Process Automation installer.
  3. Access the Third Party components install media and run the "Third_Party_Installer_windows.exe" executable.
  4. Follow the prompts, indicating location of the install, jar file location, etc.
  5. During the run, you will be prompted to provide the location of the CA Process Automation installer media.  
  6. Continue to follow the prompts, which will include the license agreement, the location of the Java/JDK Home directory
  7. You will see a dialog box that shows this.  Choose "Reinstall" and continue to follow the prompts