Processes run in ROC seem stuck at 'initializing', even after they have completed.
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Processes run in ROC seem stuck at 'initializing', even after they have completed.

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Article ID: 4302

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

When running any process via the ROC UI / designer, it hangs at 'initializing process' indefinitely and I am unable to make any progress, even when attempting to test the process.  However, if the same process is run elsewhere, such as ASAP, it completes with no issue.

Environment

OS: IndependentDatabase: IndependentVersion: >= 5.0

Cause

A Majority of the time this is going to be caused by one of two things:

 

1. The most common, a transparent proxy that is not handling HTML5 websockets correctly between the client browser and the management server causing the indefinite 'initializing' state.

2. Less likely, but still a factor from time to time, is some older browsers mishandle HTML5 websockets.

 

 

 

 

Resolution

To confirm whether or not this is the issue, while your process is stuck initializing you can either open ASAP, or bring up the JMX console of the management server to confirm whether or not the process is in fact in the state that the ROC is reporting.  If it is showing a state other than 'initializing', such as 'Finished' or 'Error', etc, you will then need to investigate which one of the above 2 causes is the culprit.  You can rule out the proxy server by simply having a machine either on the same subnet as the management server attempt the same ROC process test/run, and/or attempt to use a browser locally on the management server as well, if all works as expected this would be your issue.  As for the less likely, but possible browser issue, trying an alternate browser would typically dismiss this pretty easily.