MCS Group Profile creation or update fails. "An unknown error occurred. Check the log for more information."
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MCS Group Profile creation or update fails. "An unknown error occurred. Check the log for more information."

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Article ID: 427095

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I can't create new MCS Group profile as I'm getting the following error: 

 "An unknown error occurred. Check the log for more information."

 

I'm also unable to update any existing profile as they are seem to be stuck. 

This is happening for any probe. 

It is possible to create device profiles, only group profiles are failing like this. 

Environment

DX UIM 23.4.*

Cause

A stuck template migration can cause this issue. In the tables ssrv2probetemplaespackage and ssrv2probetemplatesupgrade , there may be some entries for packages with status of "migrating" and not "migrated".  

Resolution

Updating / forcing these stuck migration to update to OK usually resolves this issue. 

The following query can be executed: 

 

UPDATE ssrv2probetemplaespackage set status ='ok' where status = 'migrating'

Additional Information

Related KB: Internal error when trying to edit any existing profile after a migration