Pdm_ldap_sync/Pdm_ldap_import timing out
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Pdm_ldap_sync/Pdm_ldap_import timing out

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Article ID: 4258

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When running pdm_ldap_sync or when running pdm_ldap_import, the functions timeouts. In the stdlogs or from the command line, you will see the following error:

5:09/05 06:00:21.11 CA_SERVICEDESK ldap_sync 5392 ERROR ldap_sync.c 328 pdm_ldap_sync: Method 'got_ldap_domset' in Contact_Object failed (ldap_get_next_page() error: (Timeout)) 

or

ldap_get_next_page() ERROR(Timeout)

Environment

ServiceDesk 12.x - 14.xActive Directory

Cause

The cause of the issue can be because LDAP client was exceeded while waiting for a result

Resolution

1) Increase and install ldap_agents under Admin tab-> Option Manager->ldap-> num_ldap_agents

 

 Install and Increase the value to 4

 

2) Install the following variable

 

a. pdm_options_mgr -c -s LDAP_TIMEOUT -v 120 -a pdm_option.inst

b. (the 2nd run is prevent the value defaulting to oob value after running pdm_configure)

  pdm_options_mgr -c -s LDAP_TIMEOUT -v 120 -a pdm_option.inst -t 

 

3)Both options will need a ServiceDesk Recycle in order to be enabled.

 

Additional Information

Other reason why there can be a ldap timeout:

When there are over a million LDAP records, ldap_get_next_page() error: (Timeout) when searching for LDAP users. If we select File -> New contact from LDAP and use % in the Last Name field and hit search sometimes it results in a CGI Timeout