The Symantec Management Agent is unable to re-register with the Symantec Management Platform after migration
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The Symantec Management Agent is unable to re-register with the Symantec Management Platform after migration

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Article ID: 425270

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Updated On:

Products

IT Management Suite

Issue/Introduction

In a situation where the Symantec Management Agent was migrated from one virtual environment to another virtual environment, the client may fail to re-register with the server.

Policy requests also fail with the error:

The specified resource does not exist: 744af870-3eb3-4b61-8b72-f3abe2516a79
type=493435f7-3b17-4c4c-b07f-c23e7ab7781f
key=[name.domain]
value=[******]
   [UnrecoverableComException @ Altiris.NS.dll]

Environment

ITMS 8.8

Cause

In some virtualizers (QEMU) agent detects itself as a physical computer, and if previously (in VMWare, etc) it was detected as a virtual computer, it would prevent the client from re-registering with the SMP server.

Resolution

One option is to convert the machine resource type to physical on the server side, which is explained in KB170095

Or before migration, install SMA_SMP_8_8_PF_v8 update from KB400510 and upgrade the clients.

The updated agent correctly detects the machine as virtual in Proxmox VE