Import service log errors with: Cannot connect to the Import service. Contact your administrator.
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Import service log errors with: Cannot connect to the Import service. Contact your administrator.

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Article ID: 4239

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Our data synchronization from CA Software Asset Manager to CA Asset Portfolio Management is not functional.

We are receiving the following error in our import service log: 

INFO CA.Applications.ImportProcessor.Processor - ..Initializing Import service [http://<serverName:port#>/ImportService/ImportService.svc] access 
ERROR CA.Applications.ImportProcessor.Processor - Cannot connect to the Import service. Contact your administrator. 
INFO CA.Applications.ImportProcessor.Processor - Exit Code: 2 

 

Environment

CA IT Asset Manager 12.x, 14.x, 17.x

Cause

In the Server Manager, the HTTP Activation option is not installed under the WCF Services option. 

 

Resolution

Steps to resolve:

1.  Launch Server Manager

2. Navigate to Add Roles or Features

3.  Expand down to "Features" in list of pages on the left

4.  Expand ".Net 4.5 Features", or a later version of .NET, depending on your installation

5.  Under "WCF Services", check the box for "HTTP-Activation"

6.  Click "Install" Button

7.  Restart server for the changes to take effect.

8.  Repeat this process for both the APM web and application servers