AHD4409 pdmweb is unable to connect with the webengine error from Apache Web Server Access attempt
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AHD4409 pdmweb is unable to connect with the webengine error from Apache Web Server Access attempt

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Article ID: 420410

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

While attempting to access the web UI via the Apache Web Server, receiving error code AHD4409.  Error is specific to the Apache Web server (httpd daemon).  Apache Tomcat does not present with any problems and is accessible.

cURL access to the same from a Linux command line also results in an AHD4409 (expecting a result denoting binary content was detected).  

Environment

Release: All SDM Releases running Apache Web Server on Linux

Cause

The Apache Web Server was configured to operate using the PrivateTmp setting enabled.  Normally, webengine expects to write content into the common /tmp directory location.  The setting creates an isolated tmp location which can disrupt communications between webengine and Apache Web Server.

Later Linux and Apache installations will have this setting enabled by default, making this a scenario that is more common among newer installations.  The PrivateTmp setting may have also been enabled for sandboxing purposes.  

Resolution

  1. Verify if PrivateTmp was enabled.  To do this, run this command on the Linux server shell:
    sudo systemctl show httpd | grep PrivateTmp


  2. If the above returns a result such as PrivateTmp=yes or PrivateTmp=true, the setting must be disabled.


  3. Create the override directory (if it doesn't exist)
    sudo mkdir -p /etc/systemd/system/httpd.service.d


  4. Create the override configuration file (use your preferred editor)
    sudo nano /etc/systemd/system/httpd.service.d/override.conf


  5. Enter the following into the override.conf file:

    [Service]
    PrivateTmp=false

  6. Restart Apache
    sudo systemctl daemon-reload
    sudo systemctl restart httpd

Additional Information

The above changes apply specifically to Apache Web Server (httpd) and not Apache Tomcat.  These are two distinct implementations of the web server technology developed by Apache, each with their own configuration requirements and settings.  Apache Web Server is an optional web component that Service Desk supports on non-Windows implementations, most commonly Linux.  Windows would use IIS in its place.

For additional Apache Web Server settings, please see also Apache Web Server access results in "You don't have permission to access this resource"