Spectrum Alarm Notifier is not starting after an upgrade
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Spectrum Alarm Notifier is not starting after an upgrade

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Article ID: 41754

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Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading Spectrum Alarm Notifier no longer starts automatically when prior to upgrade it did.

Environment

Release: All Supported Versions
Component: SPCAPP - Spectrum Applications

Cause

This typically happens because a new directory has been created manually and the AlarmNotifier.exe files were copied into this new directory. 

Spectrum's default installation does not detect these directories and will not update any executables in custom directories within Spectrum.

The other reason could be that the ALARMNOTIFIER.idb was overwritten during the install and it needs to be adjusted to start automatically.

Resolution

If you have created new AlarmNotifier directories, you need to copy the new executable to those directories and rename them as needed.

In the ALARMNOTIFIER.idb file there are two things to look at.

1) Make sure the ALARMNOTIFIER.idb AUTOBOOTSTART is set to Y 

2) Make sure the path to the AlarmNotifier executable is correct

If you have multiple AlarmNotifier apps you may need to move the new AlarmNotifier executable to the app directories you created. Adjusting the name of the files to correspond with what is in the ALARMNOTIFIER.idb file may be necessary also.