Virtual Service specific log is not getting generated
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Virtual Service specific log is not getting generated

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Article ID: 4166

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

 Virtual service specific log is not getting generated under the logs folder. This was working before but not now.

Environment

Release: All Supported DevTest releases
Component: ITKOVS

Cause

There was change made in the log level to the property "log4j.logger.VSE".

The log level for "log4j.logger.VSE" was set to "ERROR".

The ERROR log level will only write in to the logs when there is any ERROR in the VS. If there were no Errors, the logs will not get generated. 

Resolution

Open the logging.properties from DevTest_Home folder.


Change the log level of "log4j.logger.VSE" to INFO and save the file.

 

Additional Information

Please note the virtual specific log gets generated as soon as there are transactions against this virtual service