vSAN -- vSAN Data Protection error while trying to deploy Appliance
search cancel

vSAN -- vSAN Data Protection error while trying to deploy Appliance

book

Article ID: 413599

calendar_today

Updated On:

Products

VMware vSAN VMware vCenter Server 8.0 VMware vSAN 8.x

Issue/Introduction

Receiving the following error message on the vSAN Data Protection dashboard: 

<html> <head><title>502 Bad Gateway</title></head> <body> <center><h1>502 Bad Gateway</h1></center> <hr><center>nginx/1.25.2</center> </body> </html> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page -->

 

Other errors may be seen as well

 

Example:

Environment

vCenter 8.0 U3
vSAN Snapshot Service Appliance 8.0.3.1

Cause

Incorrect Certificate being used during deployment

Resolution

Follow the instructions in, "Deploying the Snapshot Service Appliance". For the certificate, be sure so use the "Download trusted root CA certificates" link at the bottom right hand corner of the vCenter Web Client "Getting Started" page.

Additional Information

See KB for same error on existing vSAN Data Protection Appliance: 
vSAN Data protection section view is not populating in the vSphere UI followed by a VCenter reboot or Vcenter certificate renewal