Not able to post the metric value to NASS messages from the hubmon probe
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Not able to post the metric value to NASS messages from the hubmon probe

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Article ID: 407817

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

You are getting these messages repeatedly in the oi_connector logs, related to the hubmon probe: 

Aug 11 10:05:10:504 [QosExecutorService-2, oi_connector] Not able to post the metric value to NASS as either cs_id, ci_name or metric_name is not available for the record: {product=UIM, product_version=23.4.3, qosName=QOS_HUB_QUEUE_CONNECTED, origin=<example>, ip=##.##.#.#, source=##.##.#.#, target=baseline_engine.BASELINE_CONFIG, probe=hubmon 

Is this reporting an issue? 

Should we worry about these messages? 

What do these message mean? 

Environment

  • DX UIM 23.4.3
  • oi_connector 2.*
  • hubmon probe

Cause

Working as Designed. The hubmon probe is a custom probe that monitors DX UIM hubs. This field developed probe, which is not officially supported by Broadcom, does not register ci_metric_id and generates alarms and messages with out sending any ci_metric_id. 

For this reason the oi_connector is unable "to post the metric value to NASS"

Resolution

These messages can be ignored as they are informative and only appear at log level >3. 

Alternatively, through the oi_connector GUI it is possible to exclude the oi_connector to process the metrics and/or alarms coming from the hubmon probe. 

Additional Information