After changing the Nimsoft Watcher Service user on primary hub can't see dashboards in OC
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After changing the Nimsoft Watcher Service user on primary hub can't see dashboards in OC

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Article ID: 402741

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

You are using Windows Authentication and have updated the primary hub Nimsoft Watcher Service "Log On As" properties from one user to another and after this you can't see the published or any other OC Dashboards in the Dashboard webapp.

When logged with the new New user to the DX UIM Backend DB, the umpDashboard table shows empty while when logged with the original user the table shows correct entries, but still in the OC there is no existing dashboard as before this change.

Environment

DX UIM 23.4.*

Cause

When Windows Authentication is used, and the user is updated in both Nimsoft Watcher Service and data_engine the default schema of the new created user on the DB might not be defauling to [dbo]. In this scenario new umpDahboards tables were created with the a different schema, causing this tale duplication and causing the OC to refer to the new schema rather than the default that should be [dbo].

Resolution

  • Engage your DBA and backup your Production DX UIM DB Before doing any change
  • Analyze the information_schema.tables and check if there is any mismatch of TABLE_SCHEMA
  • If there are discrepancies and dashboard related tables' TABLE_SCHEMA is different from DBO, alter the schema and set it to DBO.
  • Open a Case with Broadcom support if any assistance is required. 

Additional Information