HTTP Error 500.19 - Internal Server Error after installing CA Asset Portfolio Manager
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HTTP Error 500.19 - Internal Server Error after installing CA Asset Portfolio Manager

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Article ID: 33249

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Updated On:

Products

CA IT Asset Manager ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA IT Asset Manager Asset Portfolio Management

Issue/Introduction

The following error occurs on the APM login page after installing CA Asset Portfolio Management  and modifying the web server web.config as directed by the post installation steps.

A HTTP Error 500.19 - Internal Server Error - The requested page cannot be accessed because the related configuration data for the page is invalid.

 

Environment

Asset Portfolio Manager 14.1.02 release and above

Cause

The CA Asset Portfolio Management post installation steps direct you to make the following change to the web server web.config.

Modify the Current Key with the New Key as shown next.

Current Key:

<binding name="st_importBinding"/>


New Key:

<!--<binding name="st_importBinding" />-->
<binding name="st_importBinding" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferPoolSize="524288" transferMode="Buffered">
<readerQuotas maxDepth="32" maxStringContentLength="2147483647" maxArrayLength="2147483647"
maxBytesPerRead="4096" maxNameTableCharCount="2147483647" />
</binding>
>


The resulting HTTP Error 500.19 - Internal Server Error can occur if the entry is not complete or was malformed during the copy\paste function. The entry may be missing end tags or contains incorrect double quote characters.

Resolution

Verify the entry carefully for missing tags or malformed double quotes and correct as needed. Or, manually type the entire key.

Additional Information