UI takes long time to load large number of account
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UI takes long time to load large number of account

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Article ID: 33141

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Updated On:

Products

CA Virtual Privilege Manager CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

After logging into Enterprise Management, loading the My Privileged Accounts page takes a long time.

 



Environment

Enterprise Management 12.8 and above

 

Cause

This could be due to either the My Privileged Accounts search to be too high.

Resolution

# How to adjust number of accounts loaded

1: Open IDM manager console, the URL is http://ENTMHostName:18080/idmmanage/. If it is not enabled, use the link in the Additional Information field to enable it.

2: In the idmmanage page, go to Environments > ac-env > Advanced Settings > Miscellaneous and set MyAccountsSearchSizeLimit to a lower number than its current value. The default is 100, but is sometimes configured to a larger value to allow users to see more accounts at once. The higher the value, the longer it will take the page to load.

3: Click save and restart

4: Stop jboss and remove its tmp and work folders. They contain cache information so need to be deleted when making a change like this.

On Windows: C:\jboss-4.2.3.GA\server\default\tmp & C:\jboss-4.2.3.GA\server\default\work

On Linux: /opt/jboss-4.2.3.GA/server/default/tmp & /opt/jboss-4.2.3.GA/server/default/work

Note that this may cause jboss to take longer to start, but this should only happen once as the cache is being rebuilt. Next starts should be faster.

5: Start jboss

 

If the page still takes a long time to load, you can also disable it from automatically searching upon login.

# How to disable account loaded

1: Open IDM manager console, the URL is http://ENTMHostName:18080/idmmanage/. If it is not enabled, use the link in the Additional Information field to enable it.

2: In the idmmanage page, go to Environments > ac-env > Advanced Settings > Miscellaneous and set MyAccountsTabAutoSearch to false.

3: Click save and restart

4: Stop jboss and remove its tmp and work folders. They contain cache information so need to be deleted when making a change like this.

On Windows: C:\jboss-4.2.3.GA\server\default\tmp & C:\jboss-4.2.3.GA\server\default\work

On Linux: /opt/jboss-4.2.3.GA/server/default/tmp & /opt/jboss-4.2.3.GA/server/default/work

Note that this may cause jboss to take longer to start, but this should only happen once as the cache is being rebuilt. Next starts should be faster.

5: Start jboss

 

After the work in the idmmanage page is complete, it is advised to disable the page so no other users can access it.

Additional Information

How to Enable the idmmanage Console: https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-identity-manager/12-9-02/implementing/using-the-ca-identity-manager-management-console/enable-the-ca-identity-manager-management-console.html

How to Disable the idmmanage Console: https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-identity-manager/12-9-02/implementing/using-the-ca-identity-manager-management-console/disable-the-ca-identity-manager-management-console.html