After new install of CA MSM, MSMTC fails at startup.
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After new install of CA MSM, MSMTC fails at startup.

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Article ID: 32176

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Updated On:

Products

Mainframe Software Manager (Chorus Software Manager)

Issue/Introduction

Problem:


java.lang.NoSuchMethodError: com/ca/mf20/system/SystemManager.isRunningOnZOs()Z

 

Environment:

USS, Tomcat, IE, Chrome, Firefox.

Cause:

CA MSM was reinstalled over the old /msmruntime and /msm directories after the build level maintenance was applied to them. This causes /msmruntine to have a mix of the original GA files with fhe files from later build levels.


 
Resolution/Workaround:

To resolve this, under /msmruntime delete the following:
apache-tomcat-7.0.42
dsi
tomcat
 
Also under /msm delete the following:
CEGPHFS
CEGPJAR
CEG1JAR
CEG1SHSC
datacom
dsi
 
Rerun the MSMSetup.sh script. 

Additional Information:

CA Chorus™ Software Manager Version 06.0.00 Installation Guide

https://support.ca.com/cadocs/0/CA%20Chorus%20Software%20Manager%206%200-ENU/Bookshelf_Files/HTML/CSM_V60_InstallGuide_ENU/index.htm

 

 

Environment

Release: MSMNGR00200-5.1-Chorus Software Manager
Component: