CA Spool main started task can experience sporadic S0C4-11 abends on IBM?s module EZBRERIN
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CA Spool main started task can experience sporadic S0C4-11 abends on IBM?s module EZBRERIN

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Article ID: 32003

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Updated On:

Products

Spool

Issue/Introduction

Upon deployment of IBM’s z/OS RSU1506 maintenance the CA Spool main started task can experience sporadic S0C4-11 abends on IBM’s module EZBRERIN.

A dump will be created by the IBM TCP/IP Stack Resolver Address Space with a title very similar to this:

Dump Title: RESOLVER V2R1:Job(CASPOOL) EZBRERIN(UI27255 20150520)+00009864
               S0C4/00000011 P=005B,S=005B,H=005B

 

 

 

 

Environment

This abend takes place during CA Spool cleanup processing. The ongoing print session normally completes successfully. Any z/OS system that has installed IBM’s z/OS RSU1506 maintenance is affected. No action is required other than to report the exception to IBM and follow guidance on what maintenance is required to cope with this situation.

Cause

IBM is fully aware of this and has created specific z/OS release maintenance to resolve the underlying problem.

Resolution

When contacting IBM ask for IBM APAR PI47752.  

PI47752: ABEND0C4-11 IN EZBRERIN+9980

See http://www-01.ibm.com/support/docview.wss?crawler=1&uid=isg1PI47752

Applicable component levels are :

R210 PSY UI31344   
R220 PSY UI31345  

Be aware that IBM has to be contacted to confirm the IBM APAR number and applicable PTFs for your specific z/OS system level.

Workaround:

The workaround for these symptoms includes the use of IP addresses instead of hostnames.
It can be implemented at printer level via the online menu Print panel in the extended display of the affected printer.  

Also a recycle of the CA Spool main task can temporarily fix the problem until specific IBM's z/OS release maintenance is installed/deployed.

Additional Information

There is also another symptom of the IBM TCP/IP Stack Resolver issue where abends are not happening.
Normally print sessions are interrupted and printer goes to EDRAINED status when the following message is posted:

ESF908 ... Host name couldn't be resolved 

For clients using ACQUIRE=TIME CA Spool waits for the ACQTIME= timer to expire and print file is queued.
Then during normal debugging process hostnames can be resolved by IBM TCP/IP Stack Resolver using the TCP/IP's PING protocol. 

Also print sessions complete successfully using the TCP/IP's LPR protocol performed outside of the CA Spool main task.