Unable to log into the NSX-T manager web interface: Some appliance components are not functioning properly
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Unable to log into the NSX-T manager web interface: Some appliance components are not functioning properly

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Article ID: 317798

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You may be unable to log in to the NSX Management UI, accessing the VIP or an NSX Manager, using basic authentication (with local accounts: admin, audit, guestuser).
  • One or more NSX Manager may show high memory usage under System / Appliances.
  • Responses to NSX API calls may be slower than expected.
  • You may get an alert such as:
    Some appliance components are not functioning properly.
    Suberror : 15
    Error code: 101
  • Log lines similar to the below are encountered on the NSX Manager in /var/log/proxy/reverse-proxy.log
    INFO https-jsse-nio-##.##.##.##-443-exec-513004 PAMAuthenticationProvider 25880 - [nsx@6876 comp="nsx-manager" level="INFO" subcomp="http"] Successful login for admin, groups superusers
  • Listing the processes on the affected NSX Manager appliance, you can see that the "res" column shows a high value for the uproxy service.
    • As admin: get processes monitor
    • As root: top
    PID USER      PR  NI    VIRT    RES   SHR S  %CPU  %MEM     TIME+    TGID COMMAND
    25880 uproxy 20 0 2676744 1.156g 12388 S 100.0 4.9 68865:10 /usr/lib/jvm/zre-8-amd64/bin/java -Djava.util.logging.config.file=/opt/vmware/proxy-tomcat/conf/logging.proper+

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware NSX-T Data Center
VMware NSX

Cause

There is a small memory leak in the proxy service when using basic authentication in the PAM authentication workflow.

Resolution

This issue is resolved in VMware NSX-T Data Center 3.2.3 and VMware NSX 4.1.1, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.


Workaround:

  • As root user, log into the impacted NSX Manager and restart the proxy service:
    systemctl restart proxy