Unable to log into the NSX-T manager web interface: Some appliance components are not functioning properly
search cancel

Unable to log into the NSX-T manager web interface: Some appliance components are not functioning properly

book

Article ID: 317798

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • You are unable to log into one or more of the NSX manager web interface directly (not using VIP).
  • You are unable to login the VIP address of the NSX management cluster.
  • API responses are slower than expected
  • You get an alert such as:
Some appliance components are not functioning properly.
Suberror : 15
Error code: 101
  • You use basic authentication to log into the manager appliances, that is local accounts: admin, audit, guestuser.
  • In the log '/var/log/proxy/reverse-proxy.log' of the impacted manager(s) you see the following log entries:
2023-01-18T08:44:38.766Z INFO https-jsse-nio-10.97.0.65-443-exec-513004 PAMAuthenticationProvider 25880 - [nsx@6876 comp="nsx-manager" level="INFO" subcomp="http"] Successful login for admin, groups superusers
  • If you run top and check the uproxy service, the res is quite high:
25880 uproxy 20 0 2676744 1.156g 12388 S 100.0 4.9 68865:10 /usr/lib/jvm/zre-8-amd64/bin/java -Djava.util.logging.config.file=/opt/vmware/proxy-tomcat/conf/logging.proper+

Environment

VMware NSX-T Data Center
VMware NSX

Cause

There is a small memory leak in the proxy service when using basic authentication in the PAM authentication workflow.

Resolution

This issue is resolved in VMware NSX 3.2.3
This issue is resolved in VMware NSX 3.2.4
This issue is resolved in VMware NSX 4.1.1
This issue is resolved in VMware NSX 4.2.0

Workaround:
As root user, log into the impacted NSX-T manager and restart the proxy service:

systemctl restart proxy

Additional Information

NSX Manager memory usage is gradually increasing resulting in slower API responses (KB # 322475, legacy KB # 93253) archived in favor of this article