PPM: Cannot update ETC to 0 and Task Status to Completed at same time on Task List or Task Properties page

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Article ID: 30141

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Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When trying to update the ETC of a task to 0 and mark it as 'Completed' at the same time, the following error message is received

PRJ-07235: Invalid status for task having non-zero ETC

This can occur on both the Task List page as well as the Task Properties page. It may also occur even if the ETC of the task is already 0 and the status is being updated to 'Completed'

Steps to Reproduce:

1. Go to Projects, click on a project, then go to the tasks tab.
2. Add a task and assign a resource to the task.
3. Add some ETCs to the assignment.
4. Navigate back to the task list and add ETC and Status to the column view if it's not there already.
5. Update the ETC for the task to 0, and the Status to 'Completed', and click Save.

Expected Result:

The ETC is updated to 0, and the Task Status is set to 'Completed'.

Actual Result:

The changes are not saved, and instead error: PRJ-07235: Invalid status for task having non-zero ETC is shown.

Cause

This issue is caused by CLRT-77407.

Environment

Release: ESPCLA99000-13.2-Clarity-Extended Support Plus
Component:

Resolution

The defect causing this behavior has been resolved in CA PPM 15.1 and above.

Workaround:

Update the ETC to 0, click Save, then update the status of the task separately. 
Alternatively, you can also update the Task Status to Completed in the Task Properties section, and update the ETC to 0 in the assignment section.

If this is occurring even when the ETC is already 0, modify the ETC for the task in the Task List page and set it to 0. Then you can update the status to 'Completed'.