What are the effects of keeping CLASSIC_SLA_PROCESSING set in the most recent releases of CA Service Management?

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Article ID: 28805

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

What are the effects of keeping CLASSIC_SLA_PROCESSING set in the most recent releases of Clarity Service Management?

Cause

The CLASSIC_SLA_PROCESSING is an old feature from Clarity Service Management, which makes Service Types based on Ranks. This code has remained untouched, with that, any new Service Type related functionality introduced in Clarity Service Management will not be available when this option installed. By default, a new Clarity Service Management installation does not have such option installed. However, in an upgraded environment, this option may be installed if the original environment had it set.

This document explains what the effects of keeping this option set are.

Environment

CA Service Management 17.2
CA Service Management 17.1

Resolution

With CLASSIC_SLA_PROCESSING set as ON, the Service Type tab of the ticket shows the following options related to the Service Type control:

With CLASSIC_SLA_PROCESSING OFF, the Service Type tab of the ticket shows additional options as well as functionalities:


Those options and functionalities are:

  • Projected Violation Time, Violation Cost, Violation Status and Evaluation;
  • Service Target information;
  • Additionally, setting a Service Type for a Workflow Task in for Change Orders, Requests, Incidents and Problems is available with Classic_SLA_Processing OFF.

Thus, all these functionalities are not available with CLASSIC_SLA_PROCESSING ON.

Additional Information

How to prevent the Workflow Task Service Type to be in status "Not Active" on a Change Order
In the Incident/Request detail form, an Area that contains a Service Contract doesn't appear in an environment configured for Multi-Tenancy

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