Receiving message RMOCPP06 - UNABLE TO OBTAIN CHECKPOINT LOCK in CA Deliver.
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Receiving message RMOCPP06 - UNABLE TO OBTAIN CHECKPOINT LOCK in CA Deliver.

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Article ID: 28311

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Updated On:

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Deliver View

Issue/Introduction

A locked Sysid results when the checkpoint dataset is not released in a timely manner by CA-Deliver.
CA-Deliver may be slow during peak processing times, and temporary sluggishness lasting 5 minutes
or less should be of no concern.

A condition where messages RMOQPR01, RMOCPP06, and RMOCPP05 persist for longer times
should be scrutinized.

! Warning !
Exercise extreme care when using the UNLOCK command. Never unlock the checkpoint when the
system that locks it is still functional. If, for example, a system hangs while the checkpoint on it is locked,
the system can later break free and the system can resume processing. In this case, the checkpoint would
be severely damaged if an operator had freed/unlocked it.

Environment

z/OS
CA Deliver
CA View
Multi-system environments
Single system environments

Cause

If message RMOCPP06 indicates a SID of '*UT*', it indicates that the RMODBASE batch utility has locked
the checkpoint dataset. RMODBASE locks the checkpoint dataset while it is being created. You must wait
until RMODBASE completes.  Do NOT unlock the file.   
                                                                       
Message RMOCPP05 indicates that an outstanding reserve against the volume is locking out access to the
CA-DELIVER checkpoint. You must research who is reserving the volume and take corrective action.

There are other reasons for a checkpoint file to become locked.  
                                                                       
If you determine that CA-Deliver is failing to release the checkpoint file, it is imperative that you follow one of
the following procedures to prevent corruption of the checkpoint dataset and resume normal processing.

Resolution

The procedure varies as documented below:

--- MULTI-SYSTEM ENVIRONMENTS:                                            
                                                                         
     If CA-Deliver is running in multiple systems, the system(s) should be issuing messages RMOCPP06 (every 30 seconds),
     and RMOQPR01 (up to 1 per second). Message RMOCPP06 will indicate the System ID owning the lock.                                                    
                                                                         
     To Unlock the checkpoint when message RMOCPP06 indicates a SYSID:   
                                                                         
        1) On the system owning the lock: Stop or cancel CA-Deliver.     
       
        2) On one of the other systems:                                  
            - Issue the command to unlock the checkpoint:
                
                    f rmostc,unlock                                      

            - Reply Y to message RMOCPP09.                                
            - Reply U to message RMOCPP10.                                
       
         3) On the system that was cancelled, start CA-Deliver again.     
                                                                         
     To Unlock the checkpoint when message RMOCPP06 does not indicate a SYSID (**** is in the sysid field in the message):                
                                                                         
        1)  Stop or cancel ALL of the CA-Deliver Started Tasks.
         
        2)  Bring each started task back up, one at a time.
            - If the lock has not been released, issue the UNLOCK operator        
              command for that one started task before bringing up any of the others.                                           
                                                                         
 --- SINGLE SYSTEM ENVIRONMENTS:                                           
                                                                         
     Message RMOCPP06 may result as CA-Deliver is initializing after a  problem
     has caused it to abnormally terminate.  If the message is issued for this Sysid,
     just issue the following commands:
       
           - Issue the command to unlock the checkpoint:
             
                    f rmostc,unlock
                                  
           - Reply Y to message RMOCPP09.                             
           - Reply U to message RMOCPP10.

Additional Information

See CA Deliver Message Guide:

RMOCPP06 - UNABLE TO OBTAIN CHECKPOINT LOCK - LOCK OWNED BY SID xxx

RMOCPP05 - WAITING FOR CHECKPOINT

RMOQPR01 - NO RESPONSE - VERIFY taskname IS ACTIVE (sid)