Inbound delivery is rejected with "554 5.7.1 Bad senders system address"
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Inbound delivery is rejected with "554 5.7.1 Bad senders system address"

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Article ID: 271067

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Updated On:

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Messaging Gateway

Issue/Introduction

You have found that some inbound message deliveries to the Messaging Gateway are rejected with the following response:

554 5.7.1 Bad senders system address

 

Example of full maillog below:

(info) ecelerity: [28355] LUA: DNS: No DNS record found for MAIL FROM domain XXX
(info) ecelerity: [28355] ML-REJECT: Rejection on: XXX, sent to host: XXX, Audit ID XXX, 554 5.7.1 Bad senders system address#015

Cause

The rejection response "554 5.7.1 Bad senders system address" is a result of a failed check that MAIL FROM address has neither an 'A', nor an 'AAAA', nor an 'MX' record in Domain Name System (DNS) validation feature of the Messaging Gateway with a default rejection message.

Resolution

It is vital to narrow down the issue if a DNS check can be executed or if the issue is with DNS validation - MAIL FROM does not have either an MX or an A / AAAA record.

DNS will need to be investigated to determine why the check failed and corrective steps would need to be done on the DNS records depending on the results of the investigation. MAIL FROM addresses validation can be switched off.

Additional Information