21.0 Agent will not start if JCP is unreachable
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21.0 Agent will not start if JCP is unreachable

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Article ID: 270583

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Post upgrade to version 21.x, on a system restart, agents only try once to connect to the AE / server and disconnects if server not available. In the previous versions it used to make multiple attempts to connect until the AE/ server is up and running.

Environment

CA Automic Workload Automation

Version 21.x

Cause

Working as designed.

Resolution

With version 21, the agent will only retry once to connect on startup

If during startup the system is not available., the AGENT will end.

If, rather, the Agent starts, connects to the system, and then is unable to reach the system (due to network outage, AE downtime, etc...), the agent will attempt to reconnect to the system as defined until its process is ended. 

The reason for this update is that if there is an incorrect setting in the agent ini file for the CP or JCP (incorrect IP, DNS Name, port, etc...) and the agent cannot reach it, the previous behavior would keep the agent running.  Since there is an error (unable to reach IP:port for the CP or JCP), the agent instead should end as it does with any other error.

 

Additional Information

If the agent loses connection to AE, example: Automation engine is up and running while the agent is rebooting, the agent will keep retrying multiple times for 60 seconds. But on a fresh restart it will only try once.

https://docs.automic.com/documentation/WEBHELP/English/all/components/DOCU/21.0/Automic%20Automation%20Guides/Content/AWA/Variables/UC_SYSTEM_SETTINGS/UC_SYSTEM_RECONNECT_TIME.htm?Highlight=RECONNECT_TIME