Ghost Solution Suite DAgents are not showing up in console
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Ghost Solution Suite DAgents are not showing up in console

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Article ID: 268876

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

Observation:

DAgent on an endpoint starts without error but it is not showing up in the console.

The DAgent in the System Tray does not display or shows disconnected.

 

Environment

GSS 3.x

Cause

After enabling full logging of the DAgent on the endpoint the error example is displayed like here:

[ 15:52:46.717 2564 0] DsAgent.cpp:179 caught unhandled exception connecting to DS
    common\ipc\TcpSocketIpc.cpp:71 CTCPSocketIPC::Connect Failed to connect e=0, s=10060
[ 15:52:46.720 2564 0] bootstrap.cpp:674 unhandled exception thrown from startup code
    common\ipc\TcpSocketIpc.cpp:71 - CTCPSocketIPC::Connect Failed to connect
    Value=0, SystemError=0x0000274C
[ 15:52:46.725 2564 0] DsAgent.cpp:488 About to serialize objects
[ 15:54:46.448 2564 0] bootstrap.cpp:1128 - Error reading input file.
[ 15:54:46.808 2564 0] bootstrap.cpp:464 GetCfgFilename(): strName = C:
[ 15:55:7.794 2564 0] CDSAgent::ConnectToServer() - exception thrown while trying to connect to the DS.
    File: common\ipc\TcpSocketIpc.cpp, Line: 71, Error Message: CTCPSocketIPC::Connect Failed to connect
[02/10/2016 15:55:7.796 2564 0] DsAgent.cpp:179 caught unhandled exception connecting to DS
    common\ipc\TcpSocketIpc.cpp:71 CTCPSocketIPC::Connect Failed to connect e=0, s=10060

 

Additional Return Codes observed in the DAgent logs:

CTCPSocketIPC::Connect Failed to connect e=0, s=10060
CTCPSocketIPC::Connect Failed to connect e=0, s=10061
CTCPSocketIPC::Connect Failed to connect e=0, s=10065

These are Microsoft OS Return Codes identified as follows:

Return Code 10060 is a Connection Time-out error
Return Code 10061 is a Connection Refused error sent to you by the server.
Return Code 10065 indicates that a socket operation was attempted to an unreachable host

Resolution

Areas to check:

1. The agent has the correct name/IP address of the server
2. All firewalls allow ports 402 TCP/UDP (This includes firewalls on routers/switches that are between the Ghost Server and client).
3. Check the Image State in client machine registry (This can change after sysprep to IMAGE_STATE_UNDEPLOYABLE or IMAGE_STATE_INCOMPLETE which causes issues).
     Open regedit and go to HKLM | Software | Microsoft | Windows | CurrentVersion | Setup | State | ImageState = IMAGE_STATE_COMPLETE
4. Go To - Control Panel -> Altiris Deployment Server -> Options -> Transport Tab -> disable allow encrypted sessions. Apply and save.
5. Check your anti-virus on the Client and the Ghost Server. Sometimes these services will block certain ports or connections.
6. Check that the purchased license count is less than the number of currently managed nodes.
7. If windows firewall is Enabled on the GSS Server, disable it as a test with the following command (run from the command prompt as Administrator):
      netsh advfirewall set allprofiles state off

    After testing, put the firewall back and make any needed changes for port 402.

Additional Information

See this document for how to setup AXEngine and Agent logging:  How to enable DAgent Logging from a Client

Other options to consider: On a newly imaged client machine, the Client is not connecting to the GSS console or showing up active in the Computers list