Issues with WebPortal Autologin
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Issues with WebPortal Autologin

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Article ID: 267721

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

We had few web portals configured in PAM with Autologin.

It was working until last few days, but suddenly stopped working and fails with error "Autologin Timeout expired, possibly due to Wrong credentials, Please contact Administrator"

Credentials are correct as we validated them multiple times and we are also able to do Learn mode for the same URL's but it fails when using Autologin. The same URL worked fine before we went for 4.1.2 upgrade.

Environment

Release : 4.1-4.1.3

Cause

The learn mode did not save the auto logon value for the username and password field in the web sso template. This caused the auto logon to fail because the username and password were not entered in the fields.

This issue occurred because the web portal is based on the React JS. Similar to the problem discussed in KB 267331, setting the field's value directly does not work in React JS. 

Resolution

This problem will be fixed in PAM 4.1.5+ and 4.2+. If you need the problem fixed at a lower release, open a case with PAM Support.