Service Point does not load Sevice Catalog offerings when using SAML Authentication
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Service Point does not load Sevice Catalog offerings when using SAML Authentication

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Article ID: 265266

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

When Service Point is trying to load Catalog data, the following appears in the web browser Console tab:

Refused to load the script 'https://login.microsoftonline.com/<ID>/wsfed?wa=wsignin1.0&wtrealm=https%3a%2f%2f<hostname>%3a7443%2fusm%2fwpf&wctx=%2fusm%2fwpf%3fNode%3dicguinode.buiticketsstatus%26b2b%3djson-html%26eiamArtifact%3dUserSession%3bVersion-1.0%3bdd623ec33cb797fc9d63c0b568f40b99-64257129-a79aa20-4b%26callback%3dng_jsonp_callback_1&id=passive&wct=2023-03-30T18:06:15.289Z&wreply=https%3a%2f%2fXXXXXXX%3a7443%2fusm%2fwpf' because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-inline' 'unsafe-eval' ". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.

 

Environment

CA Service Management 17.3 and 17.4

CA Service Catalog configured with SAML/Azured AD (Working OK)
CA SDM configured with SAML/Azured AD (Working OK)
Service Point configured with BASIC Authentication

 

Cause

As per design, if Service Catalog & SDM are enabled for SSO (SAML), need to set the authentication type for XFlow as SAML or else it will fail to communicate

Resolution

Enable SAML Authentication for xFlow/Service Point. Refer to the following link: Enable SAML Authentication for xFlow Interface